Access Issues on Citrix Server after Hospital Domain change

Aug 22, 2016 at 7:07 PM
Recently our hospital moved all users over to a new domain. After the domain move we were not longer to run scripts on our Citrix servers. We we running fine for quite some time prior to the move. When trying to run a script the the error is:

"Could not load file or assembly "script name.esapi.dll" or one of its dependencies. Access is denied"

We have made sure that users have read and execute rights to the location of the VMS.TPS.Common.Model.Types.dll & VMS.TPS.Common.Model.API.dll files.

What other dependencies does running the scripts have?

Finally I note that the Cirtix Servers are still on the old domain.

Thanks.
Coordinator
Aug 28, 2016 at 1:44 AM
What is the location of the scripts relative to the new domain? Are they on the domain or on a remote location? If they're on a remote location, it could be a security setting that's preventing the domain from loading your scripts.
Aug 29, 2016 at 11:33 PM
The scripts are on a shared network drive which all users should have access to. We no longer think it is a domain issue, if someone with admin rights logs on to cirtix the scripts run fine. So it looks like a rights issue to either access or run the scripts.
Sep 26, 2016 at 7:42 PM
To close this post,
the solution was a Citrix rights problem mentioned by wkeranen in a post from ~ 2 years ago. By default Citrix does not allow .exe/.dll files on network drives to be run. I had searched previous posts but somehow missed this one.
Thanks.

Here is the previous post.
https://variandeveloper.codeplex.com/discussions/546383
Marked as answer by TrapJaw on 9/26/2016 at 12:42 PM