problem running scripts in Citrix enviroment

May 23, 2014 at 4:11 PM
Dear All,
Here is the problem I have:

I have been able to compile the the example projects that I downloaded from varian developer forum (after copying the VMS.TPS.Common.Model.*.dll locally on the workstation that I run my visual studio 2010).
After the build, I see the *.dll (ex: PLanQualityMetrics.esapi.dll) created.
When I try to call this "dll" in eclipse, I get an error as "Could not load file or assembly 'PlanQualityMetrics.esapi.dll' or one of its dependencies. Access is denied"

Is this a citrix related file access issue? I would appreciate any comments/help to resolve this.
Thank you ,
May 23, 2014 at 9:04 PM
Edited May 23, 2014 at 9:04 PM
If you want to run Eclipse scripts within a Citrix environment, you may have to ask your IT people to configure Citrix. By default, Citrix environments do not let you load DLLs and run executables from foreign directories, and extra configuration is required.

See the link below.
Jun 30, 2014 at 7:25 PM
I run Citrix only and had a similar problem when I first started.
Did you properly add the VMS libraries to the references in Visual Studio?
Jun 30, 2014 at 9:40 PM
Yes. Once I located and copied the dlls locally and added to the references, the problem was solved.