VMS.TPS.Common.Model.API.dll V13.6, 13.5, and 13

Nov 6, 2015 at 8:34 PM
Edited Nov 6, 2015 at 8:35 PM
Hello everyone,

Does anyone know if a script compiled for Eclipse V13.6 using VMS.TPS.Common.Model.API.dll and VMS.TPS.Common.Model.Types.dll also be able to work in V13.5 and 13? Or are there different VMS.TPS.Common.Model.API.dll and VMS.TPS.Common.Model.Types.dll files for those versions.

Thanks,
Kurt
Coordinator
Nov 6, 2015 at 9:02 PM
Edited Nov 6, 2015 at 9:03 PM
Yes, there are different versions of the DLLs for each version.

But, if you only use the set of features available to v13 it should work since the interface is the same between versions with a number of additions getting added to each subsequent version. Exceptions / interface changes are noted in reference guides. You need to test it thoroughly for each version though; as Varian states in the reference guides "The authors of custom scripts are responsible for verifying the accuracy and correctness of the scripts after developing a new script or after system upgrade for the existing scripts."
Marked as answer by ksysock on 11/6/2015 at 1:52 PM