Help to run the PluginTester

Feb 7 at 3:22 PM
Hi,

I have developed a nice standalone script and planed to convert it to a binary plugin.
In order to do this, I tried to understand the pluginTester project and run it with the
included PluginScriptExample.

After changing the reference to 13.6 for the VMS libraries, I tried to run it, and I can't see
to make it work :

In the solution property page I have set the PluginTester as the Single startup project.

Upon running, the PluginTester ask me to login into aria (as expected) but then does not
open the mainWindow. From what I see, it stalls at :
static void Execute(VMS.TPS.Common.Model.API.Application app)
{
   Window window = new Window();
   MainWindow mainWindow = new MainWindow(app); // <= stalls here
    window.Title = "UM Plugin Tester";
    window.Content = mainWindow;
    window.Width = 1200;
    window.Height = 600;
    window.ShowDialog();
}
I guess I'm missing something rather obvious, but I can't figure out what.

Also, the developement machine is not an Eclipse machine, but it has the VMS .dll's
copied locally. This worked fine for standalone executables.

Any tips / pointers on how to proceed ?
Coordinator
Feb 25 at 7:03 PM
I don't have a solution to your problem, but you can try an alternative to the PluginTester, called EclipsePlugInRunner. I wrote it so that you don't have to edit its code to make it work.
Mar 14 at 10:16 AM
Thank you. I finally managed to be able to run the plugin tester, I just
needed to change more things in it.

Your solution seems simpler, I'll try it and use it for the next time.