Upgrade to 13.7 from 11 and scripting

Jun 13 at 5:09 PM
We have just upgraded from ARIA/Eclipse v11 to v13.7. Our script for the Plan Quality Metrics throws the error:

"Method not found: 'VMS.TPS.Common.Model.API.Dose VMS.TPS.Common.Model.API.PlanningItem.get_Dose()';"

We used this script before and it worked without any problems. Any suggestions on how to fix this? Is there a new reference library I'm not using? Thanks.
Jun 13 at 10:28 PM
Hi dkshay514,

If this is the PlanQualityMetrics script posted on this site, can you share with me which code file has the get_Dose() method? I'm having trouble finding it.
Jun 14 at 1:21 PM
mcshmidt,

Oddly enough the code doesn't have a _getDose() method but it does show up when I run it in Eclipse. It's weird. I can't find the method mentioned in the error message.
Jun 14 at 2:41 PM
I found out that I wasn't using the new references like I thought I was. I referenced the 13.7 .dll files again and it worked fine. I right clicked on the properties of the reference in C# and it showed the older version.